Trim went bad ..... - California Bass Fishing Forum
» Site Navigation
» Home
»
 > Search
 > FAQ
» Forum Search
» Insurance
Reply
 
LinkBack Thread Tools
Old 03-17-2011, 10:08 AM   #1 (permalink)
bmx
Senior Member
 
bmx's Avatar
 
Join Date: Nov 2008
Posts: 2,222
Send a message via AIM to bmx
Default Trim went bad .....

Was about to drive to clear lake for AC pro am. Went out to load boat and the trim just clicks. It did this last week for a minute but then started working again. I checked it everyday and it worked. Loaded boat up and checked it again and ..... Click. trying to get ahold of gone fishing marine. It's under warranty but itsxalso an hour away.
__________________
2013 Big fish
8.1 - 7.9 - 7.5 - 7.3 - 7.1
Mike
www.NorCalRampRats.com
bmx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-17-2011, 10:26 AM   #2 (permalink)
Senior Member
 
Join Date: Nov 2008
Posts: 2,657
Default Re: Trim went bad .....

Curious, does it do it at all trim stations or just at the rear station ?
__________________
Phil Hill
www.jigssnakebitebaits.com
JIGS is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 10:31 AM   #3 (permalink)
bmx
Senior Member
 
bmx's Avatar
 
Join Date: Nov 2008
Posts: 2,222
Send a message via AIM to bmx
Default Re: Trim went bad .....

All
__________________
2013 Big fish
8.1 - 7.9 - 7.5 - 7.3 - 7.1
Mike
www.NorCalRampRats.com
bmx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-17-2011, 10:47 AM   #4 (permalink)
Senior Member
 
Join Date: Nov 2008
Posts: 2,657
Default Re: Trim went bad .....

Check battery to see if has 12 volts.
Could be bad trim motor or bad relays, you can disconnect trim motor wires(blue and green) from trim relays and connect green wire to positive battery post and blue wire to negative battery post trim motor should run and trim outboard down, reverse blue and Green wire connection to battery post and should trim up. If it does trim motor is ok, replace both trim relays.
__________________
Phil Hill
www.jigssnakebitebaits.com
JIGS is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 10:51 AM   #5 (permalink)
Member
 
Join Date: Feb 2010
Posts: 54
Default Re: Trim went bad .....

My last merc. Did that too me twice it was a relay that snapped in and out . If I remember right it was a forty dollar fix.. if you stand behind boat after cowling is removed its on left side about the middle of motor. You can hear the relay click if you press trim button. After my experience with the problem I always carried one in boat as a spare. I hope this helps
bullybaits is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 10:57 AM   #6 (permalink)
Member
 
Join Date: Oct 2009
Posts: 31
Default Re: Trim went bad .....

Relays!!!
fishinfool74 is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 11:02 AM   #7 (permalink)
Senior Member
 
Join Date: Dec 2008
Posts: 216
Default Re: Trim went bad .....

I had that happen to me last month. Just klicked, checked my battery connections and the terminals were loose. Hasnt happened again
bassbasset is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 11:33 AM   #8 (permalink)
Member
 
Join Date: Jan 2009
Posts: 35
Default Re: Trim went bad .....

I'm about the worlds worst mechanic but if the engine will trim one way only that probably means that only one relay is bad. I think you can switch the trim tabs around to trim-up then switch them back to trim down on the transom saver. At least this way you can limp your way in to where you need to be. Also, when you get to the shop buy an extra pair of relays to keep in the boat. Its a relatively easy fix even on the water.
Timber is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 12:19 PM   #9 (permalink)
bmx
Senior Member
 
bmx's Avatar
 
Join Date: Nov 2008
Posts: 2,222
Send a message via AIM to bmx
Default Re: Trim went bad .....

At gone fishing marine now. They are on it. They are checking a few other things to make sure it's nit more than just the relay. They don't want this to happen again. Just being sure. All mechanics should be this way.
__________________
2013 Big fish
8.1 - 7.9 - 7.5 - 7.3 - 7.1
Mike
www.NorCalRampRats.com
bmx is offline   Reply With Quote Quick reply to this message
Old 03-17-2011, 12:45 PM   #10 (permalink)
bmx
Senior Member
 
bmx's Avatar
 
Join Date: Nov 2008
Posts: 2,222
Send a message via AIM to bmx
Default Re: Trim went bad .....

Trim motor is bad. Its working now though. Merc tech said bang on trim motor and it will work. They got one on order under warranty. On my way to clear lake. Hopefully i dont get stuck Thanks gone fishing marine & Mark for not just assuming what it was. Mechanics that do that suck!!!
__________________
2013 Big fish
8.1 - 7.9 - 7.5 - 7.3 - 7.1
Mike
www.NorCalRampRats.com
bmx is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the California Bass Fishing Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB - Evinrude Tilt and Trim Assembly ash Boats and/or Motors for Sale 0 07-16-2012 04:08 PM
Power trim? brambo Northern California 3 08-28-2011 02:33 PM
Need a Lowrance LCX 111,112 or 113 trim bezel brian carnahan Everything Else 0 08-09-2011 12:32 PM
Trim problem ??? 96nitro Northern California 3 07-03-2010 11:04 PM
trim problems barse41 Northern California 1 03-05-2009 12:28 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 12:54 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL3
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.