sycho 520c - California Bass Fishing Forum
» Site Navigation
» Home
»
 > Search
 > FAQ
» Forum Search
» Insurance
Reply
 
LinkBack Thread Tools
Old 09-19-2011, 09:35 PM   #1 (permalink)
Member
 
Join Date: Dec 2010
Posts: 35
Default sycho 520c

I have a 520c on my deck that os wiggn out. It stopped working out of the blue, but would work at the console. I checked the fuse on the deck power source and it was in fact blown. So I replaced the fuse plugged it in and nothing. Tried to plug it in at the console again and nothing. Its now been 2 weeks since I wrote it off as gone, and plugged it in again at the console and it turned on. Tried to plug it in on deck and nothing. The fuse is still in tacked and know will not work again at the console.

ANY IDEAS? Im a little confused!
Bjohnson is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-23-2011, 03:37 PM   #2 (permalink)
Senior Member
 
Join Date: Nov 2008
Posts: 203
Default Re: sycho 520c

With blown fuse issues you do have power problems. As for why it would work at the console when there was a blown fuse up front and then not work anywhere again, I would think the power inconsistency there may be problems inside the unit now. This would take a call and explanation to Lowrance customer service and see what they have to say. Their number is 1-800-324-1356.
__________________
Ken Sauret
http://www.lowrance.com/
http://kensbassfishing.weebly.com/
http://www.dobynsrods.com/
http://www.yamaha-motor.com/
Ken Sauret is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the California Bass Fishing Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LMS 520c RicharddaPlumber Lowrance Info & Support Forum 3 05-25-2012 04:44 PM
520c Bruce Lowrance Info & Support Forum 1 04-10-2012 07:31 PM
Lowrance 520c tcs Rods, Reels, and Tackle 6 08-01-2011 02:35 PM
520c changeout fresnobassman Lowrance Info & Support Forum 1 06-27-2011 09:08 PM
Help with Lowrance 520c Roger Saraiba Northern California 4 10-14-2009 02:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 06:27 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL3
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.